Tags

, , , , , , ,

I’ve recently purchased some Iris components from Ebay and it seems if the devices are paired with another Hub before, then you may need to reset them so it can be added to yours.

You may also try resetting if your having general issues trying to add devices to your Iris hub too.

This is is what you need to do for the Range extender.

1) Unplug the Range Extender from the outlet.

2) Press and hold the button on the front of the Range Extender for 15 seconds by using a paper clip or pin.

Range Extender reset

3) Plug the Range Extender back into the outlet

4) Immediately press the button on the front of the Range Extender 8 times, once per second

If it’s done correctly it it should flicker twice after every second.
Example: flicker, flicker, pause one second, flicker, flicker, pause one second.

From my experience you may need to try this 2-3 times before it resets successfully. By then your allowed to add the range extender to your hub.

**Update 7/5/2013**

If the instructions above still doesn’t work for you. Then you may want to try the modified steps provided by Mike’s comment below.

1) Unplug the Range Extender from the outlet.
2) Press and hold the button on the front of the Range Extender for 30 seconds by using a paper clip or pin.
3) Plug the Range Extender back into the outlet
4) Immediately press the button on the front of the Range Extender 10 times, once per second

##If it still doesn’t reset then try plugging the Range Extender it into a different outlet and repeat step 4 above again